Apple Store тиркемесин жүктөө үчүн iOS 10 же андан кийинки версия талап кылынат

IOS 10.3 бета нускалары бизге белгилерди берип жатат келечекте iOS 11 кандай болушу мүмкүн же жок дегенде жаңы жаңылануу кайда баратат. Айкыныраак нерселердин бири - iOS 11 64-бит тиркемелерге гана уруксат берет, Ошентип, колдонуучулары 32-биттүү иштеп чыгуучулар жаңыртылат же өлүп калат.

Apple компаниясынын мисалы айдан ачык. Колдонмолоруңуздун көпчүлүгү, iWork пакети сыяктуу (Барактар, Сандар, Негизги белгилер) талап кылынат iOS 10 же андан жогору версия аларды биздин түзмөккө жүктөп алуу үчүн. Apple Store тиркемесинин акыркы жаңыртуусунан кийин Big Apple дагы бул критерийди өзгөрттү: мындан ары iOS 10дон жогору тиркемелерди гана жүктөөгө болот.

Apple компаниясынын талаптары барган сайын көбөйүүдө: азыр iOS 10 же андан жогору

Apple ар дайым өзүнүн түзмөктөрүндө жана экосистемасында кемчиликсиздикти каалайт, ага мен тиркемелерди жана башка дүкөндөрдү киргизем. Операциялык тутумдун бардык чыгарылыштарында, Cupertino's иштеп чыгуучулардын өнүгүшүнө же өлүшүнө аргасыз кылган бир катар өзгөчөлүктөрдү чыгарды. Бул керек иштеп чыгуучулар iOS, macOS жана башка операциялык тутумдардагы өзгөрүүлөргө ылайык алга илгерилешет.

Эгер эсибизде болсо, in Февраль 2015 Apple компаниясы иштеп чыгуучуларды 2015-жылдын февраль айынан кийин жүктөлгөн колдонмолор менен шайкеш кылууга мажбур кылды 64 бит:

1-жылдын 2015-февралынан баштап, App Store дүкөнүнө жүктөлгөн жаңы iOS колдонмолорунда 64 биттик колдоо көрсөтүлүшү керек жана Xcode 8 же андан кийинки версияга кирген iOS 6 SDK менен курулат. Долбооруңузда 64 биттик алкакты иштетүү үчүн, Xcode'дун демейки "стандарттык архитектурасы" параметрин колдонуп, 32 биттик нускалары жана 64 биттик коду менен экилик бинар курууну сунуштайбыз.

Ошол күндөн баштап бүгүнкү күнгө чейин тиркемелердеги бардык өзгөрүүлөр ушул аркылуу колдоого алынышы керек 64-бит архитектура. Бирок Apple компаниясы iOS 10 же андан жогору версиялары үчүн жаңыртылбаган тиркемелерди жок кылары жөнүндө кабар келип түштү жана iOS 10 иштей баштаганда App Store дүкөнүндөгү колдонмолордун дээрлик 11% таасир этет деп күтүлүүдө.

Колдонмодо Apple дүкөнү, акыркы жаңыртууда буга чейин камтылган iOS 10 же андан жогору версиясына ээ болуу талабы, өз тиркемелерин иштеп чыгууда артта калган иштеп чыгуучулар үчүн жарылуу.


Макаланын мазмуну биздин принциптерге карманат редакциялык этика. Ката жөнүндө кабарлоо үчүн чыкылдатыңыз бул жерде.

Комментарий биринчи болуп

Комментарий калтырыңыз

Сиздин электрондук почта дареги жарыяланбайт. Милдеттүү талаалар менен белгиленет *

*

*

  1. Маалыматтар үчүн жооптуу: AB Internet Networks 2008 SL
  2. Маалыматтын максаты: СПАМды көзөмөлдөө, комментарийлерди башкаруу.
  3. Мыйзамдуулук: Сиздин макулдугуңуз
  4. Маалыматтарды берүү: Маалыматтар үчүнчү жактарга юридикалык милдеттенмелерден тышкары билдирилбейт.
  5. Маалыматтарды сактоо: Occentus Networks (ЕС) тарабынан уюштурулган маалыматтар базасы
  6. Укуктар: Каалаган убакта маалыматыңызды чектеп, калыбына келтирип жана жок кыла аласыз.