Tutorial: instalar Whatsapp en el iPhone 3G

Whatsapp en el iPhone 3G

Mucho hemos hablado estas semanas de la última versión de Whatsapp, que elimina la compatibilidad con el iPhone 3G, en principio funcionaba si tenías una versión antigua de la app, pero si querías instalarla de cero, o si la habías borrado, restaurado, etc. ya no podías volver a instalarla. Luego dejó de funcionar en todos los iPhones 3G, y después volvió a funcionar en algunos dispositivos, pero como he dicho solo si tenías la versión antigua de la aplicación.

Mucho se ha opinado en los comentarios sobre el tema, unos dicen que Apple debería dar soporte al iPhone 3G y crear una nueva versión de iOS para él, otros opinan que el iPhone 3G es un dispositivo muy antiguo, con unos recursos limitados y que ya ha llegado su hora, que no se puede dar soporte eternamente a móviles tan antiguos. De cualquier forma os vamos a enseñar a instalar la última versión de WhatsApp en el iPhone 3G.

Es muy sencillo, Whatsapp requiere iOS 4.3 para funcionar, y el iPhone 3G solo llega a iOS 4.2.1… pues hagamos que el iPhone 3G crea que tiene iOS 4.3. Para ello evidentemente necesitamos jailbreak.

Puedes hacerlo con cualquier aplicación que de acceso a los archivos del iPhone, desde el propio iFile en el iPhone, usando una herramienta de acceso SSH como Ciberduck o con programas tipo iFunfox para Windows. Una vez accedas a los archivos del iPhone solo tienes que buscar la ruta:

/system/library/coreservices

Dentro de esa ruta debéis localizar el archivo “SystemVersion” y editarlo, con algunas herramientas deberéis descargarlo al ordenador, editarlo y después volver a subirlo, con otras podréis hacerlo directamente. Lo dicho, editad ese archivo, en la parte final del texto, está la version de vuestro iOS, veréis que pone iOS 4.2.1, lo editáis y ponéis 4.3 o 4.3.1 donde ponía 4.2.1, guardáis y reiniciáis el iPhone.

Si vais a Ajustes>General>Información veréis que la versión de vuestro iPhone es 4.3, no es cierto, sigue siendo 4.2.1, pero ahora podréis instalar (desde la App Store) WhatsApp y otras tantas aplicaciones que requieren iOS 4.3.

Actualización: parece que este truco solo le funciona a algunos usuarios, comentad vuestra experiencia en los comentarios.

Más información – Whatsapp vuelve a funcionar a algunos usuarios con iPhone 3G

Los mejores accesorios para tu iPhone
¿Buscas una funda nueva para tu iPhone? ¿Un accesorio para el Apple Watch? ¿Quizás un altavoz Bluetooth? No te pierdas estas ofertas en accesorios y saca el máximo partido al móvil de Apple:
Fundas iPhoneAltavoces BluetoothAccesorios Apple Watch

279 comentarios, deja el tuyo

  1. sirve tambien para un iphone 2g?

  2.   DaviD dijo

    Muy interesante.. Esto sirve para instalar aplicaciones de iOS 6 en iOS 5? Por ejemplo la última versión de Shazam?

  3.   Ju dijo

    Se puede en un iPod 3G ?????

  4.   M.B dijo

    sería de mucha utilidad y ayuda si haces el tutorial completo y no poner; editas con alguna herramienta, lo bajas al ordenador y luego lo subes… se agradece que querais ayudar pero la ayuda esta a medias.

    1.    Gnzl dijo

      Se puede hacer de 20 formas diferentes, todas explicadas con anterioridad.
      No puedo explicarlas todas. Pero la más sencilla es buscar ifunbox y descargarlo, no hay que hacer nada, es un gestor de carpetas como el propio Explorer. No tiene nada que explicar.

      1.    M.B dijo

        dices que ifunbox es para windows, tengo mac. Igual estoy intentando con Myfile y la verdad no se que estoy haciendo pero intentando llegamos a America.

      2.    iphone dijo

        Ayudenme, no entiendo la parte que dice EDITAS CON UNA HERRAMIENTA, LO BAJAS AL PC Y LUEGO LO SUBES con que herramienta puedo hacer esooo’?

  5.   David Hernandez dijo

    servira para un ipod touch?

    1.    Gnzl dijo

      Si

    2.    Kmari dijo

      lo he probado en un 2g y nada, empieza con la descarga y al momento de instalar no pasa a mas, la app desaparece. Igual y si lo logras, avisas como lo has hecho vale? 🙂

  6.   Carl24 dijo

    Hice todo a pie de palabra y no me funciona. Cuando reviso la versión del iOS desde el iPhone me dice que tengo instalada la 4.3, al igual que cuando lo conecto a iTunes me dice que tengo iOS 4.3, pero cuando quiero instalar WhatsApp 2.8.7 me da error porque no es compatible.

    1.    Gnzl dijo

      Pues yo lo conseguí ayer, es raro, a los demás os funciona?

      1.